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Getting Started 
Technical Support 

 

Welcome to the instructional manual for the Multi-Vendor Catalog module within the Eagle 
Business Management System (EBMS).  Eagle Solutions is pleased to provide you with 
instructions and tips regarding the Windows version of EBMS.  In the sections following, 
explanations and examples of the available features in the Eagle Business Management System 
will be explained for optimal use of the System.  If you need to reach our staff for further help, 
contact us using the information below: 

 

 

 

 

 

 

Eagle SolutionsEagle SolutionsEagle SolutionsEagle Solutions    

5351 Lincoln Highway, Suite 9 

Gap, PA 17527 

(717) 442-3247 x2 

(717)-442-1096 fax 

www.EagleBusinessSoftware.com 

Email: Support@EagleBusinessSoftware.com 
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Overview 

The Multiple Vendor Catalog module is an EBMS add-on that allows the user to view or select 
parts or products from a vendor supplied product list or file.   This module includes many powerful 
features that allow the user to accomplish the following: 

 

• The user can view information from multiple vendors, with varied file formats, from a 
common interface without adding all the parts into the EBMS inventory system.    

• The vendor supplied parts information can be viewed or selected from within EBMS 
using the inventory list dialog.   This allows the user to select a product from a vendor-
supplied list from within an EBMS invoice. 

• Product information can be copied into the EBMS inventory database without retyping 
descriptions, costs, and other details from the vendor’s product list. 

• List pricing, unit costs, UPC codes, and other information can be updated directly from a 
list or file supplied by a vendor.  

  

Vendors distribute their product information in a variety of file formats with a variation of product 
information.    Organizing and viewing this valuable information with a common interface can save 
a lot of time and frustration.    Not only can this information be viewed from within EBMS but the 
information can directly update inventory items within EBMS. 

 

The following file formats are recommended: 

• Dbase II, III, IV or FoxPro - *.DBF  (No conversion required) 

 

Converted by MS Excel 

• Excel - *.XLS  

• Comma delimited - *.CSV 

• Text (Tab delimited & fixed width) - *.TXT  

• Data interchange - *.DIF 

• Lotus 123 – *.WKS, *.WK1, *.WK3, *.WK4 

 

Refer to the Creating an EBMS Compatible File Using MS Excel  

 

This module simplifies inventory management within EBMS since only selected items are 
imported into the EBMS inventory list.   This minimizes clutter within the user’s product list. 
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This Multiple Vendor Catalog module can also be used to update the EBMS inventory file with 
new pricing based on a specific date.    Export the current price list into MS Excel and then import 
back into EBMS at the time the changes are required. 
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Adding a New Vendor 
Catalog 
Creating a EBMS Compatible File Using MS 
Excel 

All Vendor Catalogs must be converted to a Dbase or FoxPro compatible file (*.DBF) in order to 
be read by this product.    

 

When using MSExcel to convert a spreadsheet into a database file, it becomes important to first 
define the data in the spreadsheet cells with characteristics that are compatible with and which 
will convert to the data format of database cells. 

 

Complete the following steps using Microsoft Excel: 

 

1. Open MS Excel.  Microsoft Excel is included in all MS Office suites or can be purchased as 
a separate application.    MS Excel or MS Office can be purchased at any computer 
software store. 

2. Select the Open option from the File menu within MS Excel and the following dialog will 

open: 
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3. Set the Files of Type option to All or the specific file type that is being imported. 

4. Select the file to import.  Excel may use an import wizard depending on the data type.   
Complete the import wizard to import the data in each column into Excel so that each field 
or column in the file is within separate cells in Excel. 

5. If data appears as "######" (cell data overflow error) or "3.2986+E11" (scientific notation for 
cell number overflow error), columns of the spreadsheet must be expanded to resolve 
overflow errors.  Cells with overflow errors are likely to be discarded during conversion. 

6. The data must be formatted to specific standards to successfully convert to a Dbase format.   
(Use the Eagle WDBMaint utility to change the format if the original file is in DBF format.)  
Repeat the following formatting steps for each column based on the type of data within the 
column: 

a) Time Data – Time data will not be converted to dBase properly without using the TEXT 
worksheet function within Excel.  For example, to change the time 12:34 PM to text 
data, use the function =TEXT("12:34", "hh:mm AM/PM").  Complete the next step (Text 
Data) as well for time data. 

b) Text Data – Information such as part numbers, IDs, alphanumeric codes, and numeric 
codes such as phone numbers must be formatted as text (left justified). 

i) Highlight column - Highlight the entire column by clicking on the column label above 

the data (Example: A for the first column) 

ii) Format as Text - Select Format > Cells to format cell.   Select Text category within 
the Number tab.  Do not use cells formatted as General since text that appears as 
formulas could alter the text. 

iii) Set column font to Currier - Apply a monospaced font such as courier within the 
Font tab. 
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iv) Adjust column width - Select Format > Column > Autofit Selection.   This step will 
widen the column to the maximum width required to include all text.  If the text 
information in a column is greater than the visual width of the Excel, cell the data 
will be truncated. 

c) Numeric Data  

i) Highlight column - Highlight the entire column by clicking on the column label above 

the data  

ii) Format as Date - Select Format > Cells to format cell.   Select Number category 
within the Number tab.  Note that all text within this column becomes null when 
copied into the dBase file. 

iii) Do not use the "1000 Separator" option. 

iv) Set the ‘Negative Numbers:’ selection to ‘-1234.10’ 

v) Set number of decimals – Most numeric fields within EBMS are set with 2 decimals 
although cost fields may have more than two. 

d) Date Data 

i) Highlight column - Highlight the entire column by clicking on the column label above 

the data  

ii) Format as Number - Select Format > Cells to format cell.   Select Date category 
within the Number tab.   

e) Inventory UPC Code Data  

i) Special treatment is required.  A UPC is composed solely of numbers, however it 
must be converted to alpha-numeric data. 

ii) Highlight column - Highlight the entire column by clicking on the column label above 

the data  

iii) Format as Text - Select Format > Cells to format cell.   Select Custom category 
within the Number tab.  Do not use cells formatted as General since text that 

appears as formulas could alter the text. 

iv) Set the ‘Type:’ selection to ‘000000000000’ [12 zeros].  It is also imperative that 
UPC codes be exactly 12 digits long.  If this format option is not present, you will 
need to define it. 

Complete the steps listed above for each column. 

7. Enter a field label for each column in row one if it does not already exist.   To add labels 
above row one, highlight a cell on row one and select Insert > Row from the Excel menu.   

Enter a field name into each column describing the text. 

8. Enter a data definition for each column in row two if it does not already exist.  To insert a 
line for definitions, highlight a cell on row two and select Insert > Row from the Excel menu. 

a) For those columns of data that should be considered alpha-numeric (i.e. characters or 
text), place one (or more) Z’s in the cell of row #2. 
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b) For those columns of data that should be considered as numeric, place one or more 9’s 
in the cell of row #2.   

9. Identify the data that is to be saved in the database.   If there is no range named "Database" 
on the sheet, the data in all directions to the first empty row or column will be saved.  To 
specify a range select Insert > Name > Define. Name a range "Database" and specify the 
range of the database in the Refers To entry. 

10. Save data as a DBF file.  All formatting must be done before the file is saved as a DBF file.  Select File > Save As 
from the Excel menu to open the following dialog: 

 

 

11. Save the file in the EBMS data directory.  Select File > Company > Advanced Tab from 
the EBMS menu to view the current Data Path. 

12. The Save as type setting must be set to DBF 4 (dBase IV). 

13. Enter a file name that identifies the vendor and click on the Save button to save the file. 

 

Repeat the steps listed above for each Vendor Catalog file. 

 

Review the steps of creating a file index and connecting the file to EBMS in the next section. 
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Creating a relationship between the Product 
Catalog and EBMS 

A vendor’s product catalog file must be in dBASE (*.DBF) format and must be saved in the 
company’s data directory before continuing with this section.   See the previous section for details 
in using MS Excel to convert files to the DBF format. 

 

1. Select Inventory > Options from the EBMS menu and click on the Vendor Catalogs tab 
as shown below: 

 

 

 

2. Click on the New button to open the catalog dialog: 
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3. Enter the Catalog File name or click on the lookup button to the right of the field to select 

the database from the file list.    

4. Enter a brief Description of the product catalog. 

 

5. Select the appropriate Key Type.  This setting determines how product information within 
the catalog file is related to the EBMS inventory items.    The key must be unique for every 
product in the catalog.  The following options are available: 

 

• Manufacturer + Manufacturer Part Number – This option links the vendor catalog field 
names entered in the Key Expressions to the manufacturer and part number in the 
fields on the Inventory Item General tab.  This option should be used if the manufacturer 

of the products distributes the product catalog that is being created. 

• UPC Code – This setting should be used only if the UPC Code is the only unique product 

ID in the vendor’s catalog. 

• Inventory ID – This option should be used if the EBMS inventory ID is the same as the 
vendor’s part number in the catalog.  The inventory ID within EBMS can also be created 
by a dBase formula within the ID expression.   

• Distributor + Distributor Part Number - This option links the vendor catalog filed names 
entered in the Key Expressions to the vendor and part number in the Purchasing tab of 
the fields on the Inventory Item.  This option should be used if the distributor rather than 
the manufacturer is distributing the product catalog. 
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6. Enter the Key Expression(s).   The vendor catalog field name containing the part number 
or id should be typed in the expression field without quotes or any other punctuation.  
These expressions will normally contain field names but may contain static text or dBase 
formulas.   All static text must be enclosed with double quotes.   For example if the entire 
products catalog is from a single manufacturer or distributor, the manufacturer or 
distributors id should be enter as "FORD" including the double quotes.    

 

Reminder: The combination of all the Key Expression information must be unique for every 

product that is imported into EBMS. 

7. Click the Next button to continue. 

 

 

 

The fields within the product Catalog Expressions must be associated to the Inventory 
Fields found in EBMS.   Click on the Catalog Expressions on the left and drag them (by 
suppressing the left mouse button) to the appropriate Inventory Field on the right.   A 

connecting line will show to indicate the associations between the two files.     

8. Right click on the connecting line and select Delete Link to remove a link.    

This association will determine what information is copied from the vendor’s catalog file into 
EBMS when a new item is created in inventory.    

9. Click Next to continue. 
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EBMS facilitates information updates from Vendor Catalogs such as price, UPC, or part 
number changes.    Review the Updating a Vendor's Product Catalog section of this 
manual for more details and features of this update.      

10. Select the information that is to be copied to EBMS during the update procedure by 
checking the field OFF or ON. 

11. Click the Next button to continue. 
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Any column checked on this page can be used to sort the products within the vendor’s 
catalog.     Removing the check marks of fields or columns that will never be used to sort 
will enhance performance of the list. 

 

Click the Finish button to complete. 

 

You can change the values set by this wizard by selecting the product catalog from the list and 
clicking on the Properties button.  Note the tabs to change General, Links, Update, and Sort 

controls. 
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Using the Vendor Catalog 
Creating Inventory Items from a Product 
Catalog  

 

The Multiple Vendor Catalog module can be a time saver when a larger number of inventory 
items as well as item details need to be entered into EBMS.  Product information can be copied 
directly into the EBMS inventory database without retyping descriptions, costs, manufacturer’s 
part numbers, and other details from the vendor’s catalog. 

 

It is not recommended that vendor products be inserted into the EBMS inventory item database 
unless the products are purchased or sold by the user.   Inventory items can be easily viewed and 
created at the time they are entered in a purchase order or sales invoice.   

 

Complete the following steps to insert products from the vendor catalog into EBMS: 

 

1. Select Inventory > Inventory Items from the EBMS menu and click on the Catalog 

button. 

2. Select the desired catalog from the drop down menu as shown below. 
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3. Find the desired inventory item and select the Import button as seen below. 
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If the item is not in EBMS inventory the import will take you through the new inventory 
item wizard and the association in the Links tab of the catalog properties  will determine 
what information is copied from the vendor’s catalog file into EBMS when a new item is 
created.   

 

For more information on adding a new inventory item, review the Inventory>Inventory 
Items>Entering New Inventory Items section in the main manual. 

To see what links are set, go to Inventory > Options > Vendor Catalogs > Properties button > 
Links tab section as seen below. 
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If the item is already in EBMS inventory you will get the following message. 
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Viewing and Sorting 

Finding items in a vendor catalog file is simplified with the Multiple Vendor Catalog module.  The 
columns in a vendor catalog file that can be sorted are determined by the user. 

 

To see what columns can be sorted go to Inventory > Options > Vendor Catalogs > Properties 
button > Sort tab as seen below. 

 

 

 

To sort or to find an item in a vendor catalog open the vendor catalog by selecting Inventory > 
Inventory Items  from the EBMS menu and select the desired catalog by clicking on the Catalog 

button. 

 

Click on the title of the column in the vendor catalog that you want to sort or search.  A triangle 
and a search box will appear for that column as seen below.  (Example: The description field is 
being sorted.) 
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Updating a Vendor Catalog 
Loading an Updated Catalog 

 

1. Convert the updated vendor catalog file into a Dbase or FoxPro compatible file if the file 
is not in the proper format.  For more information on converting a file review the Creating 
a EBMS Compatible File Using MS Excel section. 

2. Save the new file in the EBMS data directory and overwrite the old vendor catalog file.  
Select File > Company > Advanced Tab from the EBMS menu to view the current Data 
Path. 

 

Make sure the new data file’s headings are exactly the same as the old database 
headings and make sure the file name is the same. 

3.  Before using the new Vendor Catalog, it must be reindexed.  Go to File>Utilities> 
Maintenance Utilities.   (Example below.  The Mega.dbf file will be reindexed.)  Select 
only the File Maintenance Utility.  Click on the Settings button. 

 

 

 

4. Enter the file name of the vendor catalog. 

5. Select OK 

6. Select  Next 
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You should get the message below when the reindex is finished. 

 

 

 

7. Select Finish 

8. Go to Inventory > Options >Vendor Catalogs > Properties button > Sort tab and set 
the fields that need to be sorted.  All the other properties of the vendor catalog should 
be the same as the old vendor catalog. 
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Updating prices and other information from 
the new file 

 

Updating inventory items in EBMS from a vendor catalog is fast and simple once the correct 
parameters are set. 

 

The updated inventory items are controlled by going to Inventory > Options > Vendor Catalogs 
> Properties button > General tab.  The items that will be updated are the items that the Key 
Type Field matches the Key Expression in the vendor catalog.  (Example #1 below:  The 
Inventory ID of the inventory item in EBMS needs to match the field in the vendor price catalog 
called ID.) 

 

 

 

(Example #2 below:  The Manufacturer field of the inventory item in EBMS needs to contain 
Ford and the Manufacturer Part Number field in EBMS needs to match the field in the vendor 
price catalog called ID.) 
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The fields to be updated in the Inventory item are controlled by going to Inventory > Options > 
Vendor Catalogs  > Properties button > Update tab as seen below.  (Example below:  The 

fields Base Price and Cost will be updated in the EBMS inventory items.) 
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After the new vendor price catalog in saved into the EBMS data directory and the correct 
parameters are set up, Select Inventory > Options > Vendor Catalogs > Update button.  The 
screen below will appear. 
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Select the Vendor Catalog that needs to be updated by putting a check mark in the Update field 
and select the OK button.  (Example above:  The EBMS inventory items that are linked to the 

Mega Vendor Catalog will be updated.) 

 

After the utility is finished the following screen will appear with the number of items that have 
been changed.  (Example below:  Four EBMS inventory items were changed or updated from the 
new vendor price catalog.) 

 

 

 

Select Finish to exit the update utility. 
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